 Ayuda Visual Bibliotecas
Visual Bibliotecas ®
Ayuda Visual Bibliotecas

INTRODCION

Si no ve bien la ayuda pulse aquí: Ayuda emergente

Puede descargar este manual en formato PDF para que pueda imprimirlo en el siguiente enlace: Manual en PDF

Para descargarse el fichero de ayuda y guardarlo en su ordenador como ayuda local: Ayuda Visual Bibliotecas® Guarde el fichero en la carpeta c:\archivos de programa\floressoft\Visual Bibliotecas\Ayuda\ayudavb.chm (Reemplace el existente). Si tiene un sistema de 64 bits, la carpeta es c:\archivos de programa (x86)\FloresSoft\Visual Bibliotecas\Ayuda\ayudavb.chm

El programa Visual Bibliotecas es útil para llevar un control de toda clase de libros, documentos, CD'S, Películas en DVD......, así como también de los lectores a los que se les hace el préstamo.

Hay mucha gente que en sus casas tiene una gran biblioteca, a la que va añadiendo publicaciones a lo largo de los años llegando a olvidarse de aquellos primeros ejemplares que adquirió. Usando el programa Visual Bibliotecas tendremos un control de todos los libros que hemos ido adquiriendo. Pero no solo podemos llevar un control de los libros que tenemos, también de discos, CD's, películas, revistas, videojuegos.......

El programa es muy potente, lo que permite llevar desde una pequeña biblioteca a grandes bibliotecas (Permite llevar más de 1 billón de ejemplares, ampliable según las necesidades, sin incluir sus correspondientes documentos asociados). Además funciona en redes de área local. Se puede adaptar también para funcionar con bases de datos SQL, lo que permitiría trabajar desde diferentes localidades y hacer ilimitada la capacidad del programa.
El programa lo podemos ampliar en poco tiempo para adaptarlo a sus necesidades.

Para dar de alta nuevos libros, categorías o nuevos lectores se utilizan estos botones. Con ellos, se maneja todo el programa.

Last Updated: 05/01/11 | © Floressoft, S.A., 2011


 CATEGORIAS, SUBCATEGORIAS Y DIVISIONES
CATEGORIAS, SUBCATEGORIAS Y DIVISIONES

CATEGORIAS Y SUB CATEGORIAS

Desde ésta ventana iremos dando de alta cada una de las categorías.

CATEGORIAS

Para dar de alta cada una de las categorías pincharemos sobre el botón [image] situado en la esquina superior izquierda, que nos sitúa en la ventana "Detalles", rellenamos los campos de Categoría y sub categoría.

La tabla que aparece debajo nos muestra todos los títulos relacionados con esa categoría y subcategoría.

Para dar de alta nuevas sub categorías, tenemos que seleccionar primero la Categoría a la que pertenece y luego pulsar el botón Nueva sub categoría. Es decir, una categoría puede tener múltiples sub categorías. Luego, los libros se pueden filtrar por categorías, y dentro de esta por sus correspondientes subcategorías.

Se ha incorporado un nuevo campo denominado Materias, que sirve para filtrar por el mismo contenido libros que estén en diferentes categorías. Por ejemplo: se tiene la categoría Ciencias y dentro de esta dos sub categorías; Matemáticas y Física, se podría poner un elemento común dentro del campo Materias (cuántica) para que buscase en ambas subcategorías. El campo materias puede admitir varias palabras, que pueden estar separadas por comas.

En el ejemplo que viene con el programa se han utilizado diferentes formatos para las subcategorías. En la nueva versión del programa existe un campo específico para el Formato, con lo que la clasificación por categorías y sub categorías puedes ser otra diferente de la del ejemplo.

Si la categoría o sub categoría contiene algún libro, no se podrá eliminar, pero si cambiarla el nombre.

El botón PREDETERMINADA, sirve para establecer la subcategoría que aparece por defecto al seleccionar una categoría cuando estamos dando de alta un libro.

En la pestaña DIVISIONES podemos crear tantas divisiones de la subcategoría como queramos.

Además se pueden introducir códigos de clasificación denominados COD. DEWEY. y que es el que aparece al listar categorías entre paréntesis. (Se puede dejar en 0)

El uso de categorías no es obligatorio aunque es muy recomendable ya que funcionan mejor los filtros del programa.

DIVISIONES

Las divisiones, sirven para organizar la biblioteca por alguna de las clasificaciones internacionales que existen de catalogación de bibliotecas como por ejemplo el código Dewey.

Last Updated: 05/01/11 | © Floressoft, S.A., 2011


 LIBROS
LIBROS

LIBROS

Es la página principal de la aplicación, aparecen todos los archivos ordenados por categoría, subcategoría y formato.

Pinchando sobre cualquiera de ellos, vemos debajo de la tabla si está prestado o no.

Además de esto, nos ofrece la posibilidad de realizar una búsqueda rápida de los libros que tenemos archivados, para ello damos al botón [image] permitiéndonos así realizar el filtro por categoría, título, autor y editorial entre otras opciones, como podemos comprobar en la siguiente imagen.

Realizamos la búsqueda por ejemplo por el título del libro, pinchamos sobre el botón [image] y seguidamente nos selecciona la lista de libros que tenemos archivados con dicho título. Los filtros se basan en palabra contenida, es decir no hace falta poner el título exacto, sino alguna palabra que contenga el titulo.

El botón de buscar que aparece en la parte superior de la pantalla, busca por el título que empiece por la palabra introducida, a diferencia de filtrar. A la derecha del de buscar, aparece otro botón de filtrar, que es un filtro rápido para títulos, autores o editorial.

Si de nuevo queremos que nos aparezcan todos los libros que tenemos en nuestro archivo, tendremos que dar en el botón

Además están los filtros instantáneos por Categoría - Subcategoría, formato e idioma. En esta pantalla es para filtrar. En la pantalla de DETALLES DE LA OBRA, se puede modificar la Categoría - Subcategoría, formato o idioma al que pertenece el libro.

Junto a los datos del lector aparece el botón FICHA. Sirve para acceder a la ficha del préstamo.

También se puede pulsar el botón de la impresora y acceder a la hoja de préstamo que es el préstamo en otro formato. (Tamaño de papel A5)

PUBLICAR SQL

El botón PUBLICAR SQL sirve para subir los libros que aparecen en pantalla al servidor SQL. Previamente se ha tenido que instalar SQL Native Cliente de Microsoft. Además se tiene que haber dado de alta la biblioteca en Internet en el menú Publicar en Internet/SQL.

Last Updated: 09/29/09 | © Floressoft, S.A., 2011


 Búsquedas y filtros
Búsquedas y filtros

Búsqueda y filtrado de libros.

Existen dos botones en la parte superior uno para buscar libros (El de los anteojos) y otro para filtrar los libros (El del rayo).

Las búsquedas de libros se realizan de la siguiente manera.

Primero busca que el titulo empiece por la cadena que hemos introducido.
Segundo busca el código EAN13, o código de barras que viene en el libro.
Tercero busca el ISBN
Cuarto, busca el código alfanumérico del libro, que se puede introducir tanto con guiones, como sin guiones.
Por último, busca el código numérico del libro.

en cuanto encuentra uno se interrumpe la búsqueda.

El filtrado de los libro, selecciona aquellos libros que contengan la palabra que hemos introducido en los siguientes campos:

Título, autor, ISBN, EAN13, tejuelo, Código alfanumérico, librería y estante (Hasta 50.000 libros). Para mas de 50.000 libros se recomienda usar el filtro avanzado.

Existe un filtro avanzado, que además filtra por la palabra contenida en: titulo, autor, editorial, librería, estante, colección, notas del campo memo.... Los campos indicados aquí en azul filtran el campo si contiene la expresión indicada. Los que aparecen en blanco, filtran el campo si es igual a la expresión indicada.

El filtro avanzado lo que hace es obtener una imagen de los datos que cumplen las condiciones. El filtro superior o filtro rápido, filtra sobre los datos obtenidos con el filtro avanzado.

Siempre se filtra sobre categoría, subcategoría ,formato e idioma que están en la pantalla principal.

Last Updated: 09/08/09 | © Floressoft, S.A., 2011


 Préstamo de Títulos
Préstamo de Títulos

PRETAMO DE TITULOS

Para anotar el préstamo pinchamos sobre el botón [image] y nos aparece la siguiente pantalla:

Buscamos por D.N.I. del lector, (previamente a sido dado de alta en "lectores" pinchando sobre el botón [image])y seguidamente nos aparece su nombre y apellidos.

El programa crea una ficha del lector con todos los libros que tiene prestados, a la que se accede desde la ventana principal en el botón FICHA. Para ello introducimos los demás libros que se prestan en OTRAS REFERENCIAS. Esto permite prestar varios libros a la vez.

Para anotar la fecha de devolución, pinchamos sobre el botón [image], anotamos la fecha en que se devuelve y pulsamos "devolver"

En la parte de arriba aparece la lista con la referencia de todas las fichas que tiene abiertas el lector, es decir aquellas de las que queda todavía por devolver algún libro. En la parte de abajo aparece la lista de los libros correspondientes a esa ficha. Así por ejemplo si de una ficha no se devuelven todos los libros, se eliminarían de la lista de libros, antes de pulsar el botón DEVOLVER.

Last Updated: 09/08/09 | © Floressoft, S.A., 2011


 Detalle de la obra
Detalle de la obra

DETALLE DE LA OBRA

En ésta pantalla anotaremos el autor, la editorial, las notas y podremos adjuntar fotos o archivos relacionados con la obra.

Si pinchamos sobre la pestaña "Web asociada" y seguidamente sobre el logotipo del Ministerio de Cultura podremos buscar la obra por autor, código ISBN, nombre, editorial.... y si nos interesa dicha información la podemos copiar y pegar en "Notas del libro"

Para adjuntar una foto pinchamos sobre el botón [image]. La foto del libro debe ser el primer documento (dentro de Documentos/Escáner), para poderla visualizar aquí.

El botón IMPRIMIR CODIGO DE BARRAS, permite imprimir el código de barras del libro o el tejuelo.

CODIFICACION DE LOS LIBROS

El nº de libro o código alfanumérico, consta de tres campos, y debe ser único para cada libro. El primer campo es numérico, y puede servir por ejemplo para el año de publicación del libro. El segundo campo es alfa-numérico de cuatro caracteres y distingue mayúsculas de minúsculas, puede servir para diferenciar los diferentes tipos de libros o la librería en la que está por ejemplo. El tercer campo es la numeración correlativa respecto del segundo campo. El segundo campo, el alfa-numérico se puede dejar en blanco, pero luego para las búsquedas hay que introducir 4 espacios.

A parte del número de libro, los libros tienen un código único de libro numérico (el número que aparece en rojo) y que también aparece encima del listado de libros, y que se puede utilizar también para realizar búsquedas.

Last Updated: 09/08/09 | © Floressoft, S.A., 2011


 Datos anexos obra
Datos anexos obra

DATOS ANEXOS OBRA

A través de esta pantalla podremos anotar otros datos generales de los libros, como por ejemplo si pertenece a una colección, las ediciones que haya tenido, si se le ha concedido algún premio así como otros datos que aparecen a continuación.

Para introducir los datos en esta pantalla lo primero que tenemos que hacer es seleccionar el libro a través de la Lista de Títulos, posteriormente vamos a la ventana de Datos anexos obra, y para poder escribir damos al botón [image] apareciendo así una serie de campos en blanco donde podremos escribir los datos correspondientes.

Si no se pulsa dicho botón, toda esta información auxiliar no ocupa espacio.

OTRAS MATERIAS

En el campo OTRAS MATERIAS (USO LOCAL) podemos añadir todas la materias que estén relacionadas con el libro y por las que también se va a filtrar al introducir la materia en el filtro avanzado.

Los campos que indican uso local quieren decir que no se suben al servidor a la hora de publicar los libros.

DICCIONARIO DE PALABRAS

Muchos de los títulos de los campos se pueden cambiar para llamarlos de otra manera que nos venga mejor. Esto se hace en el menú Utilidades-Diccionario de palabras. Aquí origen sería el nombre original del campo y traducir el nombre que queramos que aparezca en lugar del original.

Last Updated: 09/08/09 | © Floressoft, S.A., 2011


 Foto - Archivo
Foto - Archivo

FOTO - ARCHIVO. Enlazar documentos.

Con este botón: , se pueden enlazar y guardar archivos en la base de datos. Existes tres formas de enlazar:

a) Guardas como Foto.

Suele ser para guardar las carátulas de los libros. Se tiene que especificar que es una imagen o foto, para que se pueda luego visualizar. Las caratulas del libro o las fotos del mismo, se deben guardar en el primer registro. Se pueden guardar otras fotos del libro a continuación.

b) Guardar archivo en la base de datos.

Está opción sirve para almacenar cualquier tipo de documento en la base de datos. La capacidad de la base de datos es de 2 Gb. por libro. Con esta opción, no sería necesario tener el documento original, ya que guarda una copia en la base de datos.

c) Enlazar - Multimedia File.

Esta opción, a diferencia de la anterior, no guarda el documento en la base de datos, sino que guarda la ruta al archivo, por lo que es necesario conservar este.

Para entonos en red es mejor la opción b. Si el fichero es muy grande se puede usar la opción c. Si se enlaza (opción C), es muy recomendable guardar los ficheros en una carpeta dentro de [mis documentos]\FloresSoft\Visual Bibliotecas, al mismo nivel que donde está la carpeta DATA, con la base de datos, para que no se pierdan las referencias guardadas al fichero, al cambiar de ordenador o de usuario, ya que se podría perder la referencia a donde está ubicado el archivo.

Last Updated: 09/08/09 | © Floressoft, S.A., 2011


 Documentos / Escaner
Documentos / Escaner

DOCUMENTOS ESCANER

Digitaliza documentos y fotografías directamente en el escritorio en formatos de archivo conocidos, como PDF Y JPEG.
Una vez preparado el documento a escanear damos al botón [image] y a continuación a [image], seguidamente aparece una pantalla para seleccionar el modo del escáner y volvemos a dar al botón

Se puede escanear en formato PDF, que es el típico para documentos y puede ser de varias páginas, o escanear en formato JPG para una foto o documento de una sola página y que ocupa mucho menos. Para el formato JPG, se puede elegir el porcentaje de compresión (Q) de la imagen para que ocupe menos espacio.

En función del tipo de imagen que se desee digitalizar podemos elegir entre distintas opciones permitiéndonos incluso que la calidad sea lo más ajustada posible al documento original, para ello tenemos la siguiente pantalla:

Una vez seleccionada las opciones damos a DIGITALIZAR y comienza el proceso de transmisión de datos.

Al acabar de escanear, el documento nos aparece en la pantalla principal de dicha pestaña. Para poder acceder a él tenemos que dar al botón [image], llevándonos a otra pantalla desde la cual podemos, entre otras posibilidades, guardar el documento en el escritorio o en la ubicación que deseemos, adjuntarlo a un correo electrónico, etc.

Desde esta página podemos crear un documento en Word, para ello damos sobre el botón [image] y nos enlaza directamente con un documento nuevo de texto, donde podemos escribir cartas, informes o cualquier otro escrito que se desee y guardarlo en el programa, e incluso nos permite adjuntar dicho documento a un correo electrónico.

Last Updated: 09/08/09 | © Floressoft, S.A., 2011


 Histórico
Histórico

HISTÓRICO

Una vez seleccionado el título de una obra, si pinchamos en "Histórico", nos aparecen las fechas en las que se ha prestado, las fechas de devolución y los lectores.

Pulsando el botón imprimir sala un informe con la ficha completa de la obra.

Last Updated: 09/08/09 | © Floressoft, S.A., 2011


 Web asociada
Web asociada

WEB ASOCIADA

Si pinchamos sobre la pestaña "Web asociada", el programa nos lleva a la web de Floressoft, s.a., en el centro nos aparece un icono del ministerio de cultura y ciencia, si pinchamos sobre él, conectamos con la web del ministerio, donde podemos buscar información sobre cualquier obra.

Se puede navegar a cualquier Web y luego guardarla con el botón que tiene el disco y la carpeta con el clip.

Last Updated: 09/08/09 | © Floressoft, S.A., 2011


 LECTORES
LECTORES

LECTORES

A través de esta página tendremos acceso a la lista de lectores con sus datos personales.

Last Updated: 09/29/09 | © Floressoft, S.A., 2011


 Lista
Lista

LISTA

Lista de todos los lectores a los que se les ha prestado libros, CD'S, revistas....., ordenados por apellidos, nombre y D.N.I.

Last Updated: 09/08/09 | © Floressoft, S.A., 2011


 Detalles
Detalles

DETALLES

Desde esta pantalla se van a ir introduciendo los datos personales de cada uno de los lectores D.N.I, apellidos, nombre, dirección y teléfono.

Para dar de alta un nuevo lector pincharemos sobre el botón situado en la parte superior izquierda de la aplicación [image] y rellenaremos los datos, seguidamente pulsaremos sobre el botón [image] para guardar los datos

Como vemos en esta pantalla, nos permite incluir la foto del lector así como la impresión de ésta en tamaño carnet. Las fotos de los lectores se recomienda que ocupen menos de 50 Kb., ya que el límite de la base de datos es de 2 Gb.

Se puede diseñar el modelo del carnet en utilidades.

Last Updated: 09/08/09 | © Floressoft, S.A., 2011


 Histórico
Histórico

HISTORICO

En ésta pantalla se muestra la lista de libros que han sido prestados por lector, es decir, dependiendo del lector que seleccionemos aparecerá un lista u otra, indicándonos además las fechas de préstamo y de devolución de los libros.

Last Updated: 09/08/09 | © Floressoft, S.A., 2011


 INFORMES
INFORMES

INFORMES

La aplicación nos da la posibilidad de sacar por pantalla y de imprimir los siguientes informes:

- ETIQUETAS LIBROS

- CÓDIGOS DE BARRAS
El programa viene preparado para etiquetas APLY Ref. 01294

- LISTADO DE LIBROS ALFABÉTICO

- LISTADO DE LIBROS POR CÓDIGO (Código interno del programa)

- LISTADO DE LIBROS PRESTADOS

- LIBROS POR LIBRERIA/ESTANTE

- CARNETS DE LECTORES

Last Updated: 03/08/10 | © Floressoft, S.A., 2011


 UTILIDADES
UTILIDADES

UTILIDADES

Copia de seguridad:

Recuerde que es conveniente realizar copias de seguridad periódicamente para salvaguardar sus datos.

Esta aplicación también nos permite las siguientes opciones:

Diseñar etiquetas

Diseñar carnets

Copiar datos a directorio

Seleccionar o Establecer directorio de trabajo

Configuración

Last Updated: 03/08/10 | © Floressoft, S.A., 2011


 TRABAJO EN RED
TRABAJO EN RED

FUNCIONAMIENTO DEL PROGRAMA EN RED

Para poner el programa en red se deben copiar los datos en una carpeta compartida. Esto se puede hacer desde el menú utilidades-copiar datos a directorio, donde seleccionaríamos una carpeta a la que tengan acceso los demás ordenadores. También se puede copiar directamente la carpeta [mis documentos]\FloresSoft\Visual Bibliotecas a una unidad de red u otra carpeta compartida. No copie nunca la carpeta sobre una ya existente.

Se deben otorgar permisos de control total para los diferentes usuarios de windows que van a acceder a esta carpeta compartida antes de que accedan con el programa ya que si no se podría estropear la base de datos.

Una vez copiados los datos a una carpeta de acceso compartido, usamos la opción del menú utilidades: Seleccionar directorio de trabajo, para cambiar a ese directorio y que el programa trabaje ahí.

Para usar el programa en red, se debe instalar el programa en cada uno de los ordenadores, luego en el menú utilidades - seleccionar directorio de trabajo, enlazaríamos con la carpeta que hemos creado para uso compartido, en el apartado anterior.

Por último, para que el programa seleccione al arrancar la carpeta compartida seleccionamos: Utilidades - Establecer directorio de Trabajo. (El programa puede solicitarle la adquisición de una nueva licencia al hacer esto).

El directorio, donde está trabajando actualmente el programa aparece en pantalla.

NOTA: Se pueden tener varias carpetas diferentes, con diferentes bibliotecas.

USUARIOS

Al conectar con la carpeta de red, el primer usuario que conecta se convierte en Owner (Dueño). El nombre del usuario es obligatorio ponerlo, la clave o contraseña se puede dejar en blanco.

El usuario Owner, tiene permisos de lectura y escritura y puede modificar el nivel de los demás usuarios.

Los demás usuarios que intenten conectar con la carpeta de red, una vez introducido su nombre, son dados de alta en el sistema, pero no podrán acceder a la base de datos hasta que sean autorizados por el Owner desde el menú Archivo-Usuarios, estableciéndole un nivel por debajo de 4.

Los usuarios Master puede leer y escribir, pero no pueden modificar los permisos de los otros usuarios.

Los usuarios Senior sólo pueden leer, a no ser que se establezca un permiso especial de grabar datos que aparece en una de las opciones.

Los usuarios Junior no tienen acceso al sistema.

Es altamente recomendable tener al menos dos usuarios Owner, por si se avería el ordenador y no se puede volver a entrar como owner.

¿ Cómo dar de alta a un usuario nuevo desde el propio ordenador ?

Una vez introducido el nombre de Nuevo Usuario, pulsamos con el botón derecho del ratón sobre la opción Guardar. Aparecerá un desplegable con los usuarios de la base de datos. Seleccione uno de los Owners e introduzca su clave. Seleccione después el nivel del nuevo usuario, por defecto se le establece como Owner.

Es conveniente poner contraseñas a los Owners.

Last Updated: 06/04/10 | © Floressoft, S.A., 2011


 Actualizaciones Automáticas
Actualizaciones Automáticas

Actualizaciones utomáticas.

El programa se actualiza automáticamente con la mejoras que vamos incorporando al mismo. Siempre puede descargar también la versión completa que encontrará en nuestra página Web.

Last Updated: 06/04/10 | © Floressoft, S.A., 2011


 Copias de seguridad
Copias de seguridad

Los datos del programa se guardan en la carpeta:

[MIS DOCUMENTOS]\FloresSoft\Visual Bibliotecas

Es recomendable realizar copias de seguridad de esta carpeta en un CD o disco extraíble fuera del ordenador.

El programa realiza automáticamente dos copias de seguridad diferentes, cada 20 días.

NOTA: Las carpetas que guarda los datos son DATA, FICHEROS y DATAAG (para la agenda).

Last Updated: 09/29/09 | © Floressoft, S.A., 2011


 Instalación en Red
Instalación en Red

INSTALACION DEL PROGRAMA

El programa debe instalarse en cada uno de los puestos u ordenadores que lo vayan a usar y luego conectar a los datos a través de una carpeta de uso compartido al ordenador que hace de servidor.

Los datos iniciales se guardan en [mis documentos]\FloresSoft\Visual Bibliotecas. Podemos copiar las subcarpetas que contiene (DATA,FICHEROS...) a una carpeta compartida dentro de la red, o bien hacer esto desde el programa con las siguientes opciones.

Para esto utilizaremos el menú utilidades.

1º) Copiar datos a directorio. Sirve para copiar los datos actuales a otra carpeta de uso compartido en la red.
2º) Seleccionar directorio. sirve para cambiar de carpeta y conectarnos a la carpeta que se ha creado previamente.
3º) Establecer directorio de trabajo. Con esta opción, indicamos al programa que arranque en la carpeta en la que estamos actualmente. (La del paso 2).

Es recomendable dar un nombre especifico a esta carpeta para diferenciarla, por ejemplo DOCUMENTOS - OFICINA. También es recomendable conectar a través de una unidad de red a esta carpeta para mejorar el funcionamiento del programa. No se debe compartir la carpeta [mis documentos]\FloresSoft\Visual Bibliotecas, porque se guardan configuraciones del usuario del programa de ese ordenador, y afectarían al resto de usuarios de la aplicación. No se recomienda que el nombre de la ruta completa a la carpeta sea de más de 180 caracteres.

El programa se da con dos licencias, una para uso local y otra para conectar en red. Los cambios de tarjeta de red, implican una nueva licencia. (Uso en red local)

Las licencia, para uso del programa a través de terminal server, o por más de un usuario a la vez, se dan para el número de usuarios que utilizan la aplicación al mismo tiempo.

Se recomienda dejar paso a través del Firewall a los programas vlibros.exe y actualizav_bibliotecas.exe que están en la carpeta c:\archivos de programa\FloresSoft\Visual Bibliotecas para recibir las actualizaciones y mejoras del programa automáticamente. Estas actualizaciones son gratuitas para el ordenador donde se halla instalado el programa.

Last Updated: 06/04/10 | © Floressoft, S.A., 2011


 Mantenimiento de la base de datos
Mantenimiento de la base de datos

MANTENIMIENTO DE LA BASE DE DATOS

El programa cuenta con un sistema excelente de protección de la base de datos en caso de desastre.

También se puede usar para regenerar los índices si vemos que el programa tiene un funcionamiento extraño.

Para ejecutarlo, cerramos las ventanas y vamos al menú Ayuda - Mantenimiento de la base de datos.

Pulsamos sobre Indexar y Empaquetar: Seleccionamos ALL TABLES y PACK. Luego hacemos lo mismo para los ficheros.

Pese al sistema de recuperación, se recomienda hacer copias de seguridad de los datos fuera del ordenador.

Se crea también una copia cada vez que se modifica una tabla en ficheros llamados .BAK y .TBK además de las copias de seguridad que se realizan periódicamente en el ordenador local y se guardan en la carpeta "copias_de_seguridad", se realizan hasta 4 copias en fechas diferentes.

Last Updated: 09/29/09 | © Floressoft, S.A., 2011


 Servidor SQL propio
Servidor SQL propio

Publicar los datos en un Servidor SQL propio

El programa incluye la posibilidad de publicar parte de nuestros datos en servidor SQL que tengamos disponible.

Para ello, debemos seleccionar la opción Servidores SQL propios en el menú utilidades-configuración

Last Updated: 06/14/09 | © Floressoft, S.A., 2011


 Alta de la biblioteca
Alta de la biblioteca

Alta de la biblioteca en el servidor SQL

Para publicar el catálogo de libros en el servidor SQL, primeros debemos darnos de alta en el mismo desde el menú Publicar en Internet/SQL - Alta de la biblioteca en Internet/SQL

Tenemos que disponer de un servidor SQL y tener instalado el SQL Native client. Microsoft tiene la versión express que es gratuita: SQL SERVER EXPRESS EDITION

Una vez que seleccionamos el menú Alta de la biblioteca en Internet/SQL aparece la ventana para conectarnos al servidor SQL

Existen tres opciones para conectar:

a) Localhost

Esta opción es si el servidor se encuentra en nuestro ordenador

b) DNS

Se puede crear una conexión ODBC y seleccionarla desde aquí.

c) Introducir el nombre del servidor o dirección IP del mimo, el usuario y la contraseña. Esta es la opción recomendada, ya que así no nos pedirá establecer la conexión constantemente.

Una vez que hayamos conectado, nos aparecerá la ventana para solicitarnos los datos de nuestra biblioteca. Es recomendable poner un Nick.

Last Updated: 06/15/09 | © Floressoft, S.A., 2011


 Publicación de libros
Publicación de libros

Publicación de los libros en el servidor SQL

Vamos a la pantalla de libros o principal de la aplicación.

Una vez en la ventana de los libros, filtramos aquellos que queramos publicar. Sólo se publican los que aparecen en pantalla. Luego pulsamos el botón PUBLICAR SQL.

Los libros que ya han sido publicados y no ha habido modificaciones se saltan a no ser que se seleccione la opción Forzar Publicar

Las notas no se publican a menos que se especifique.

Last Updated: 06/14/09 | © Floressoft, S.A., 2011


 Libros del servidor
Libros del servidor

Libros del Servidor SQL

A esta pantalla se puede acceder pulsando el botón SQL. Si ya teníamos una conexión establecida mediante nombre de servidor y usuario, no nos la volverá a pedir. Si accedemos a través del menú, nos volverá a solicitar la conexión.

La pantalla nos permite realizar consultas de los libros en la base de datos SQL de forma similar a la pantalla principal de la aplicación.

Si se eliminan libros, sólo se eliminan los de nuestra biblioteca, no los de otras.

Last Updated: 06/14/09 | © Floressoft, S.A., 2011


 Publicar en Internet
Publicar en Internet

PUBLICAR LOS LIBROS EN INTERNERNET

El programa permite publicar parte del contenido de la base de datos en Internet.

Esto se puede realizar de dos maneras.

a) Publicar el contenido de los datos en un servidor de FloresSoft.

b) Publicar los datos en nuestro propio servidor.

Last Updated: 04/12/11 | © Floressoft, S.A., 2011


 Publicar en servidores de FloresSoft
Publicar en servidores de FloresSoft

PUBLICAR EN SERVIDORES DE FLORESSOFT

La publicación de los libros en nuestros servidores se puede realizar de dos maneras:

a) Permitir el acceso público a los datos.

Esto significa que cualquiera que entre en la página web: bibliotecas.floressoft.com puede ver los libros.
Esta forma de publicar es gratuita.

b) De forma privada.

Las personas que accedan a la página web bibliotecas.floressoft.com deberán conocer el Usuario y la Password para poder ver los libros. Este usuario y password, será el que elijamos nosotros al seleccionar la opción privada dando de alta la biblioteca.

Esta forma de publicar, tiene un coste adicional al programa.

Ambas opciones se configuran en el menú Publicar en Internet - Alta de la biblioteca en Internet

Last Updated: 06/14/09 | © Floressoft, S.A., 2011


 Publicar en servidores SQL privados
Publicar en servidores SQL privados

PUBLICAR EN SERVIDORES DE FLORESSOFT

Para poder publicar los datos de nuestros libros en nuestro propio servidor SQL Server 2005, debemos marcar esta opción en el menú Utilidades-Configuración.

Al marcar esta opción, nos pedirá las opciones para conectar con el servidor.

Esta opción lleva un costo adicional al programa.

Ponemos a disposición de los usuarios nuestras páginas web, para que la instalen en su propio Internet Information Server.

Pueden descargarlas en: ftp.floressoft.com

El USUARIO: VBILBIOTECAS
password: WEBVIRTUAL

Copie la carpeta a su servidor y configúrela como una aplicación ASP.

Abra el fichero: db_connection\dbconnect_floressoft.asp y configure la conexión con su servidor SQL.

Last Updated: 06/14/09 | © Floressoft, S.A., 2011


 Conexión a Internet
Conexión a Internet

CONEXION A INTERNET

Para que el programa pueda validar el registro de instalación, es necesario que conecte a Internet. Para realizar esta conexión se tiene que verificar que Internet Explorer navega bien, es decir, que no está trabajando sin conexión y que nos abre páginas que nunca habíamos visitado. Para que conecte hay que pulsar el botón Actualizar (F5).

A veces Internet explorer se queda sin conexión, Para resolver este problema, siga estos pasos:

  1. Inicie Internet Explorer.
  2. En el menú archivo , determinar si se habilita la opción Trabajar sin conexión .
  3. Si está marcada el programa no podrá conectar a Internet.
  4. Nota Si está habilitada esta opción, aparece una marca de verificación junto a Trabajar sin conexión . Desmarque está opción.
  5. En el menú Herramientas , haga clic en Opciones de Internet .
  6. En el cuadro de diálogo Opciones de Internet , haga clic en la ficha conexiones .
  7. Asegúrese de que está seleccionada la opción no marcar nunca una conexión .
  8. Haga clic en la ficha Avanzadas .
  9. En exploración , haga clic en para desactivar la casilla de verificación habilitar elementos sin conexión que se sincronizarán según una programación y, a continuación, haga clic en Aceptar .

Last Updated: 05/10/11 | © Floressoft, S.A., 2011


 Actualizaciones Automáticas
Actualizaciones Automáticas

ACTUALIZACIONES AUTOMATICAS - FIREWALL

Para que el programa se actualice automáticamente es necesario dejar paso a través del Firewall a los siguientes programas:

c:\archivos de programa\floressoft\visual bibliotecas\actualizaV_Bibliotecas.exe
c:\archivos de programa\floressoft\visual bibliotecas\vlibros.exe
c:\archivos de programa\floressoft\visual bibliotecas\visual bibliotecas.exe

Last Updated: 04/12/11 | © Floressoft, S.A., 2011


 Copias de seguridad
Copias de seguridad

Copias de seguridad

El directoro de trabajo, donde estan guardados los datos aparece en un recuadro en la parte inferior-izquierda de la pantalla principal del programa (Cierre la ventana de libros si no lo ve).
Si no ha cambiado el directorio de trabajo, este se encuentra en la carpeta [Mis Documentos]\FloresSoft\Visual Bibliotecas.

Conviene hacer una copia de seguridad de esta carpeta fuera del ordenador.

RESTAURACION DE LA COPIA

Cerramos el programa. Realizamos una copia de seguridad de la carpeta [Mis Documentos]\FloresSoft\Visual Bibliotecas por si acaso.

Las copias de seguridad automaticas que hace el programa se guardan en la carpeta Copias de Seguridad (Dentro de la anterior). Se guardan 4 copias (COPIA1, COPIA2,..). Hay que entrar dentro de cada carpeta y ver las fechas, para ver cual es mas reciente. (Las copias se realizan semanalmente).

En la carpeta DATA, del directorio [Mis Documentos]\FloresSoft\Visual Bibliotecas, se guardan los datos de los libros y en la carpeta FICHEROS , se guardan los documentos y fotos de cada libro.

Una vez que hemos visto que copia de seguridad es mas reciente, renombramos las carpetas [Mis Documentos]\FloresSoft\Visual Bibliotecas\DATA a DATA_ROTO (Por ejemplo). Luego copiamos la carpeta DATA_BKP del directio de la copia de seguridad, o la carpeta DATA si hemos hecho una copia fuera del ordenador de la carpeta [Mis Documentos]\FloresSoft\Visual Bibliotecas, al directorio [Mis Documentos]\FloresSoft\Visual Bibliotecas y le ponemos el nombre de DATA. Si queremos restaurar los ficheros, hacemos lo mismo con la carpeta FICHEROS.

Last Updated: 04/12/11 | © Floressoft, S.A., 2011


 Copyright
Copyright

Visual Bibliotecas ® es una marca registrada de FloresSoft S.A.

Todas las condiciones generales de uso del portal así como la licencia de uso del programa puede consultarla en nuestra página web: www.floressoft.com

FloresSoft S.A.
c/ Juan Hurtado de Mendoza 17
28036 Madrid
España

Telefono +34 (923) 269497
e-mail: soporte@floressoft.com

Puede descargar este manual en formato PDF para que pueda imprimirlo en el siguiente enlace:
Manual en PDF

La ayuda local que viene con el programa es antigua. Ya no se distribuye esta versión de la ayuda con la instalación debido al tamaño que ocupa. Puede descargar y copiar a c:\archivos de programa\floressoft\visual biblioteca\ayuda\ la última versión de la ayuda en el siguiente enlace:
Ayudavb.chm

Last Updated: 05/01/11 | © Floressoft, S.A., 2011